9/21 Incident

Incident Report for MaestroQA

Resolved

This incident has been resolved. If you experience any additional issues, please reach out to our Support team via in-app chat.
Posted Sep 21, 2021 - 22:32 UTC

Update

Our team has stabilized the MaestroQA web app and lingering effects from the short outage are gone. We continue to investigate for root cause. For users that haven't refreshed their MaestroQA web page and are still experiencing issues, we recommend closing out of all of your browser tabs and logging back into Maestro to resolve any lingering issues.
Posted Sep 21, 2021 - 12:44 UTC

Update

We are continuing to investigate this issue
Posted Sep 21, 2021 - 10:43 UTC

Investigating

We had a short outage but are continuing to see some persistent effects and intermittent partial outages and are working to mitigate the effects now
Posted Sep 21, 2021 - 09:52 UTC
This incident affected: App.