Intercom Outage

Incident Report for MaestroQA

Resolved

Intercom resolved the issue and all functionality with our in-app chat has been restored.
Posted 10 months ago. May 29, 2024 - 16:24 UTC

Investigating

Intercom, our provider of in-app chat support, is experiencing an outage. All channels to contact the Maestro CX team are currently down. We are actively monitoring with Intercom and will update with status.
Posted 10 months ago. May 29, 2024 - 15:04 UTC