AWS Outage Impact on MaestroQA
Incident Report for MaestroQA
Resolved
AWS has restored their services. All MaestroQA systems and services are operational. If you are experiencing any issues, please reach out to our support team via in-app chat.
Posted Dec 08, 2021 - 15:23 UTC
Update
AWS is beginning to see recovery in the region hosting our services. Although we are not currently seeing impact to our app, we will leave this incident open for monitoring until tomorrow morning.
Posted Dec 08, 2021 - 00:27 UTC
Update
We are continuing to monitor the AWS outage, which is ongoing. Currently, our app performance is not impacted.

Additionally, our provider of in-app chat support, Intercom, is also impacted by the AWS outage. When chatting with our support team, you may experience some latency. In the event that our in-app chat becomes unavailable, you can reach out to us for support via email at team@MaestroQA.com
Posted Dec 07, 2021 - 20:58 UTC
Monitoring
AWS is currently experiencing an outage. Earlier today, that outage affected the ability to Export Scores and Reports from our app from approximately 11am - 12pm EST. That functionality has been restored and we are continuing to monitor the situation.

Additionally, our provider of in-app chat support, Intercom, is also impacted by the AWS outage. When chatting with our support team, you may experience some latency. In the event that our in-app chat becomes unavailable, you can reach out to us for support via email at team@MaestroQA.com
Posted Dec 07, 2021 - 18:47 UTC
This incident affected: AWS ec2-us-east-1.